Thread: KA24de idle and rev problem

Page 1 of 2 12 LastLast
Results 1 to 10 of 14
  1. #1 KA24de idle and rev problem 
    Join Date
    Aug 2009
    Location
    Habersham
    Posts
    169
    Okay, so, a couple of weeks ago my car started studdering like no other and smoking. So, in an attempt to fix it, I thought it was the pcv valve and it was stuck open. Well, I replaced that and that fixed my smoking problem..but it still studders like it did before..

    At idle it idles fine but has a noticeable skip and when you rev it, it is very sluggish in the rpms..

    It seems that cylinder #2 isn't firing

    I have not replaced anything ignition wise..any ideas you guys??

    ---------- Post added at 11:35 AM ---------- Previous post was at 10:58 AM ----------

    Anyone?? I need some help
    Drive.Drift.Dream. 1***8593;
    Reply With Quote  

  2. #2  
    Join Date
    Jan 2007
    Location
    marietta, GA
    Posts
    2,089
    check your spark plugs, maf, fuel injectors, timing, coil, wires, dizzy cap, then check back with us.
    Reply With Quote  

  3. #3  
    Join Date
    Aug 2009
    Location
    Habersham
    Posts
    169
    Quote Originally Posted by DjTechNick View Post
    check your spark plugs, maf, fuel injectors, timing, coil, wires, dizzy cap, then check back with us.
    Alright, I checked all that and the only thing off was the injector. #2 injector has power going to it but when unplugged it doesn't change the idle or rev of the car.
    Drive.Drift.Dream. 1***8593;
    Reply With Quote  

  4. #4  
    Join Date
    Jan 2007
    Location
    marietta, GA
    Posts
    2,089
    get yourself another injector. im sure if you put a voltmeter on it, you would be out of spec. I think they are supposed to have like 12 ohms on them from factory. anywho, get a voltmeter and ohm out the other ones, and compare them. GL
    Reply With Quote  

  5. #5  
    Join Date
    Feb 2008
    Location
    Roswizzle
    Posts
    18,736
    It could also be stuck open and flooding that cylinder with gas. Pull the plug and see if it is wet.
    Reply With Quote  

  6. #6  
    Join Date
    Aug 2009
    Location
    Habersham
    Posts
    169
    Thanks man! I'll do that!

    ---------- Post added at 01:06 PM ---------- Previous post was at 01:06 PM ----------

    Quote Originally Posted by J Squared View Post
    It could also be stuck open and flooding that cylinder with gas. Pull the plug and see if it is wet.
    Yeah, it was wet when I pulled the plug..

    I'm almost sure now that the injector is bad
    Drive.Drift.Dream. 1***8593;
    Reply With Quote  

  7. #7  
    Join Date
    Jan 2007
    Location
    marietta, GA
    Posts
    2,089
    Quote Originally Posted by J Squared View Post
    It could also be stuck open and flooding that cylinder with gas. Pull the plug and see if it is wet.
    9 out of 10 times, its just a bad fuel injector. he needs to get a multimeter, and check it.
    Reply With Quote  

  8. #8  
    Join Date
    Feb 2008
    Location
    Roswizzle
    Posts
    18,736
    Ive seen at least 5 or 6 stuck KA injectors this past year, so its worth the 30 seconds it takes to pull the spark plug I think.
    Reply With Quote  

  9. #9  
    Join Date
    Aug 2009
    Location
    Habersham
    Posts
    169
    Yes, it was worth the 30sec..lol
    Drive.Drift.Dream. 1***8593;
    Reply With Quote  

  10. #10  
    Join Date
    Jan 2007
    Location
    marietta, GA
    Posts
    2,089
    Quote Originally Posted by J Squared View Post
    Ive seen at least 5 or 6 stuck KA injectors this past year, so its worth the 30 seconds it takes to pull the spark plug I think.
    yeah, deff. it only takes a sec. to check it.
    Reply With Quote  

Thread Information
Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. sr20 idle problem
    By halfwit in forum Motor & Accessory
    Replies: 7
    Last Post: 01-23-2011, 05:36 PM
  2. idle problem??
    By BurnzSRcoupin in forum Power & Performance
    Replies: 6
    Last Post: 01-18-2010, 08:32 PM
  3. Problem with Idle! Help!
    By CaptnPooDiddy in forum Drivetrain
    Replies: 17
    Last Post: 09-01-2008, 03:56 PM
  4. idle problem?
    By juanito in forum Power & Performance
    Replies: 6
    Last Post: 05-09-2007, 12:48 AM
  5. Idle Problem
    By Stealth13 in forum Power & Performance
    Replies: 18
    Last Post: 05-07-2007, 06:38 PM
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •