Thread: ka24de rough idle and power loss

Page 1 of 2 12 LastLast
Results 1 to 10 of 14
  1. #1 ka24de rough idle and power loss 
    Join Date
    Jan 2009
    Location
    Snellville
    Posts
    260
    Lately the car would start shaking on idle and stay on 1k or above. When I smash the gas it moves slow as hell, then out of nowhere power comes back, then goes away again..etc.

    Also theres seems to be some type of clicking/chugging sound when i give it gas, and then it randomly goes away when the power comes back.

    Its all stock, plugs and wires are almost new.

    Reply With Quote  

  2. #2  
    Join Date
    Feb 2007
    Posts
    24,691
    could be knock sensor

    ---------- Post added at 07:09 PM ---------- Previous post was at 07:09 PM ----------

    or mafs, vac leak. throttle position sensor. or idle air control valve.

    probably vac leak
    Reply With Quote  

  3. #3  
    Join Date
    Jan 2009
    Location
    Snellville
    Posts
    260
    Is there anyone in the snellville area that could come back and help me check it out?

    Reply With Quote  

  4. #4  
    Join Date
    Sep 2007
    Posts
    5,677
    does your power come back when you restart the engine? if so then it might be your fuel pump. I had this happen to me when my fuel was going out, after driving the car for 5 minutes, the car would slow itself down when i get on the gas. I had to restart the engine to reprime the fuel pump, then the car would drive fine again for another 5 minutes or so.
    bitches b burnin'
    Reply With Quote  

  5. #5  
    Join Date
    Jan 2009
    Location
    Snellville
    Posts
    260
    No, I just started and restarted it and its still shaking and not too much power. It seems to cut in randomly when i change gears then go away again. Last night i thought there was a helicopter above us when i was behind the car but it turned out to be the exhaust making noise...lol

    Reply With Quote  

  6. #6  
    Join Date
    Sep 2007
    Posts
    5,677
    um then it may be vacuum related.
    bitches b burnin'
    Reply With Quote  

  7. #7  
    Join Date
    Mar 2008
    Location
    Senoia
    Posts
    836
    My Ka did the same thing, it turned out being a bad injector.
    Reply With Quote  

  8. #8  
    Join Date
    Sep 2008
    Posts
    1,409
    mine did that for awhile, no idea why
    Reply With Quote  

  9. #9  
    Join Date
    Aug 2009
    Location
    Lake Lanier
    Posts
    1,798
    Quote Originally Posted by Viperbite View Post
    could be knock sensor

    ---------- Post added at 07:09 PM ---------- Previous post was at 07:09 PM ----------

    or mafs, vac leak. throttle position sensor. or idle air control valve.

    probably vac leak
    I agree with viper. I will add dont drive it alot . When these kas start acting up something bad usually happens . headgasket, hydrolock, rod knock then sling and kaput. I am about to join the sr crew .Yeah i said it . I am done with kas after two

    ---------- Post added at 04:07 PM ---------- Previous post was at 04:04 PM ----------

    Quote Originally Posted by kevr1 View Post
    Lately the car would start shaking on idle and stay on 1k or above. When I smash the gas it moves slow as hell, then out of nowhere power comes back, then goes away again..etc.

    Also theres seems to be some type of clicking/chugging sound when i give it gas, and then it randomly goes away when the power comes back.

    Its all stock, plugs and wires are almost new.
    Unplug your idle control valve and start car. To start you will need to tap gas . See if it smooth out. keep in mind it will not idle with it unpluged.. Check voltage on tps with voltmeter see if bad. You need any of these piece i am pretty sure i got some boxed up .
    I got the FSU on it if you need it . I can zipp it send to ya or ftp it to you
    single stage paint jobs 350 if use one of my house colors. These are track jobs. So don't expect show car. I can do show jobs but I'll Ned car for awhile and a lot of cash for one.
    Reply With Quote  

  10. #10  
    Join Date
    Jun 2008
    Posts
    633
    my SOHC is doing the same exact thing....
    Reply With Quote  

Thread Information
Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. rough idle after driving
    By xXxJohnnyxXx in forum Motor & Accessory
    Replies: 8
    Last Post: 01-18-2010, 05:08 PM
  2. ka rough idle
    By samisons in forum Motor & Accessory
    Replies: 1
    Last Post: 01-15-2010, 06:45 PM
  3. KA-T rough idle problem
    By GriffinW in forum Motor & Accessory
    Replies: 12
    Last Post: 01-07-2009, 06:59 AM
  4. problem with rough idle
    By mtnwrx in forum Power & Performance
    Replies: 17
    Last Post: 12-26-2008, 04:02 PM
  5. rough idle... loss of power?
    By blackonblack2 in forum Power & Performance
    Replies: 11
    Last Post: 11-09-2008, 07:39 PM
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •